Results 1 to 3 of 3

Thread: problem installing 2010 SP1 and resolved that

  1. #1
    JohnH's Avatar
    JohnH is offline VB.NET Forum Moderator
    .NET Framework
    .NET 4.5
    Join Date
    Dec 2005
    Location
    Norway
    Posts
    15,083
    Reputation
    2803

    problem installing 2010 SP1 and resolved that

    With one of my machines VS 2010 SP1 installed without problems (from web, just for VB 2010 Express), but with another machine there was trouble. I had four Express products installed so I just downloaded the full iso first. What happened was this:
    1. started SP1 setup, 16 applicable items, got to the end of installation and then it apparently did some rollbacks, log (available from link in final dialog) reported fatal error with last item NDP40-KB2468871.exe (.Net 4 update). Installer crashed after this, then a system reboot was requested.
    2. rebooted and ran SP1 setup again, 7 applicable items now. Again it got to end and started rollbacks (took a while). Still fatal error with NDP40-KB2468871.exe in log. Again setup crashed and a reboot was requested.
    3. rebooted (perhaps), downloaded and installed NDP40-KB2468871.exe manually without any issues.
    4. ran SP1 setup again, 6 applicable items, installed successfully.


    So reading the error log and not giving up can resolve problems

    Looking more into why NDP40 failed from the SP1 iso I found this error in log:
    Error launching CreateProcess with command line = NDP40-KB2468871.exe /q /norestart /pipe SectionName_475334668 /CEIPconsent /log "C:\Users\user\AppData\Local\Temp" Error performing inpage operation.
    Research tells 'inpage' errors could relate to problems with physical media when the file is mapped on demand into virtual memory. As I was using the old MS VCdRom to mount the iso, this is probably the reason, whatever that means... I haven't had previous problems mounting iso files with this utility before and doing installations from that, and it worked fine for all other packages in the SP1 iso, but it seems it was consistent with that particular package. Also, before installing the setup verified all packages was available and fine. I could not test if installing NDP40 manually from the iso would work, because I had already done that from the web, but I found that the file had the exact same byte count as the single file downloaded, and I could copy it from the mounted drive to a fixed drive without error.
    It is perhaps not very likely anyone else is approaching this using the iso and VCdRom, but if you do and encounter same problem (ie same problem logged), installing only NDP40 first should resolve it.
    How to format posts with code blocks etc - present the problem/post properly

    Visual Studio Community 2017

  2. #2
    MattP is offline VB.NET Forum All-Mighty
    .NET Framework
    .NET 4.0
    Join Date
    Feb 2008
    Location
    WY, USA
    Posts
    1,206
    Reputation
    618
    I didn't have this problem but apparently removing .NET 4 using .NET Framework Cleanup Tool and then installing sp1 fixes this problem.

    For those who use Silverlight you'll get this message:

    Microsoft Silverlight 4 SDK - The feature you are trying to use is on a network resource that is unavailable. Seeking application package 'silverlight_sdk.msi'
    The solution is to:

    1. download Microsoft Silverlight 4 Tools for Visual Studio 2010.

    2. Extract the files to a folder on your system. (I used 7-zip for this)

    3. Run Visual Studio 2010 sp1 again and point it to the folder you created when it asks for the msi.

  3. #3
    aMinero2211 is offline VB.NET Forum Newbie
    .NET Framework
    .NET 4.0
    Join Date
    Dec 2011
    Posts
    1
    Reputation
    0

    Smile Problem Solved!

    Thank you very much!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •