Results 1 to 5 of 5

Thread: Which .Net framework?

  1. #1
    christopheraaronjohnson's Avatar
    christopheraaronjohnson is offline VB.NET Forum Newbie
    .NET Framework
    .NET 4.5
    Join Date
    Mar 2014
    Posts
    12
    Reputation
    38

    Which .Net framework?

    I compiled a program in 4.51, which of course wouldn't run on my wife computer using 4.0. I compiled in 4.0, but wouldn't run on my 4.51. Do I need to have a compiled version for every version of.net that I want to share with? Makes updated difficult. Any suggestions?
    Thanks!
    Using Tapatalk

  2. #2
    jmcilhinney's Avatar
    jmcilhinney is offline VB.NET Forum Moderator
    .NET Framework
    .NET 4.0
    Join Date
    Aug 2004
    Location
    Sydney, Australia
    Posts
    13,776
    Reputation
    1703
    The idea is that you target the version that you need and then you tell your users that they need that version installed. If you're not actually using any features specific to 4.5.1 then there's not really any point targeting it.

    That said, while I've never actually tried to confirm this, I was under the impression that 4.5.1 was an extension of 4.5 and that was an extension of 4.0, the way 3.5 extends 3.0 and that extends 2.0. If that is the case then that means that anyone with 4.5.1 installed already has 4.5 and 4.0. When you targeted 4.0 and then tried to run on your machine with 4.5.1, what actually happened?

  3. #3
    JohnH's Avatar
    JohnH is offline VB.NET Forum Moderator
    .NET Framework
    .NET 4.5
    Join Date
    Dec 2005
    Location
    Norway
    Posts
    15,080
    Reputation
    2802
    I compiled in 4.0, but wouldn't run on my 4.51.
    Sounds odd, 4.5 and 4.5.1 are replacement frameworks that uses CLR 4 or equivalent update (for example installing 4.5 removes 4.0). Version Compatibility in the .NET Framework

  4. #4
    christopheraaronjohnson's Avatar
    christopheraaronjohnson is offline VB.NET Forum Newbie
    .NET Framework
    .NET 4.5
    Join Date
    Mar 2014
    Posts
    12
    Reputation
    38
    When I tried to run the 4.0 build in the 4.51 machine, I got the not a valid windows application error. This is the same error I get running the 4.51 on the 4.0 machine. I can't upgrade the 4.0 machine because it runs windows xp.
    Using Tapatalk

  5. #5
    jmcilhinney's Avatar
    jmcilhinney is offline VB.NET Forum Moderator
    .NET Framework
    .NET 4.0
    Join Date
    Aug 2004
    Location
    Sydney, Australia
    Posts
    13,776
    Reputation
    1703
    Quote Originally Posted by christopheraaronjohnson View Post
    When I tried to run the 4.0 build in the 4.51 machine, I got the not a valid windows application error. This is the same error I get running the 4.51 on the 4.0 machine. I can't upgrade the 4.0 machine because it runs windows xp.
    Well, if you want to support Windows XP and Windows XP cannot run anything above .NET 4.0 then it should be fairly obvious that you can't target anything higher than .NET 4.0. I am surprised that an application targeting .NET 4.0 doesn't run on a machine with .NET 4.5.1 though. As I said, I've never actually tried to confirm it but I was under the impression that 4.5.1 was a superset of 4.5, which was a superset of 4.0. I'll do a bit of research to either confirm or deny that, for my own peace of mind if nothing else. Have you seen anything on the web from other people having a similar problem?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •